Supercell drive trouble shooting.



Moderators: Ghost Hip, blakemoth

Supercell drive trouble shooting.

Postby Hey_Doc » Sat Sep 06, 2014 9:27 am

Ordered, received and built the supercell. Plugged it in and started to have fun, only the distortion switch doesn't seem to change the tone in anyway. All other pots and switches function correct and I double checked the wiring against the build documents. Aside from the switch itself being bad I'm at a loss. Any ideas of what and how I need to trouble shoot the issue?
Hey_Doc

uncommitted
uncommitted
 
Posts: 4
Joined: Thu Jul 31, 2014 9:17 pm

Re: Supercell drive trouble shooting.

Postby don72129 » Mon Sep 29, 2014 4:27 pm

Hey_Doc wrote:Ordered, received and built the supercell. Plugged it in and started to have fun, only the distortion switch doesn't seem to change the tone in anyway. All other pots and switches function correct and I double checked the wiring against the build documents. Aside from the switch itself being bad I'm at a loss. Any ideas of what and how I need to trouble shoot the issue?


I've got the same issue with mine. Trying to get a schematic from mammoth.
I will post if I figure it out
don72129

uncommitted
uncommitted
 
Posts: 5
Joined: Mon Sep 29, 2014 10:24 am

Re: Supercell drive trouble shooting.

Postby Hey_Doc » Mon Sep 29, 2014 5:28 pm

I talked to them, they said check the diodes polarity in the gain stages. I emailed them directly and they sent me a schematic to check it with. Going to take a look at it tonight actually. Will let you know what happens.
Hey_Doc

uncommitted
uncommitted
 
Posts: 4
Joined: Thu Jul 31, 2014 9:17 pm

Re: Supercell drive trouble shooting.

Postby don72129 » Mon Sep 29, 2014 5:50 pm

Good deal! I'll take a look at the diodes too! Thanks!
don72129

uncommitted
uncommitted
 
Posts: 5
Joined: Mon Sep 29, 2014 10:24 am

Re: Supercell drive trouble shooting.

Postby don72129 » Thu Oct 02, 2014 12:46 am

I emailed Mammoth about getting a copy of the schematic and told them about the SPST not making in change in tone. This is the email Issac from Mammoth sent back:
"On the build, did you receive any germanium diodes (1N270s)? If not, that might account for the toggle switch issue. I have attached the schematic for you. Let me know on the diodes and if you didn't get those germaniums I will send you some. Thanks!"
With my kit I received 1N4148 diodes NOT the germanium diodes.
They should be sending me some shortly.
I'll keep you updated here.
Donny

I have ordered many items from Mammoth.com and although I've had a few issues (about the same as anywhere else I part source from) they have always been quick to respond and help me with my issue. Always at their expense.
don72129

uncommitted
uncommitted
 
Posts: 5
Joined: Mon Sep 29, 2014 10:24 am

Re: Supercell drive trouble shooting.

Postby Hey_Doc » Thu Oct 02, 2014 8:12 am

Funny that's the same one I got as well. Yeah had few issues but they always come through. Thanks for info.
Hey_Doc

uncommitted
uncommitted
 
Posts: 4
Joined: Thu Jul 31, 2014 9:17 pm

Re: Supercell drive trouble shooting.

Postby don72129 » Sun Oct 05, 2014 9:23 am

I received the 1n270 diodes from mammoth and it fixed my switching issue. The supercell sounds very good.
don72129

uncommitted
uncommitted
 
Posts: 5
Joined: Mon Sep 29, 2014 10:24 am


Return to Mammoth Electronics



Who is online

Users browsing this forum: No registered users and 1 guest


Sponsored Ad. (Please no inflated/repetitive clicking. Thanks!)

Advertisements help support ILF


ilovefuzz.com is not responsible for user-submitted content. Users participate at their own discretion and risk.