Page 1 of 1

piece of shit amp keeps destroying tube

PostPosted: Fri Mar 10, 2017 7:53 pm
by goosekevin
i have an older peavey classic 30 that keeps fucking up. normal low volume use often had crackles and pops sometimes but it doesn't seem like too much of an issue until....it become Very Much an issue and very loud bangs and crackles started and one of the tubes looked like it had lightning inside of it. so i replaced the tubes, no biggie. then it happened again quite quickly with the new set, so i just replaced the problem tube. now it has happened again to a different tube and im fucking sick to shit of it.

what do i do beyond 'take it to a tech'
is this a bias issue? fixable? or is the amp just fucked

thanks in advance for help, sorry if this is the wrong section

Re: piece of shit amp keeps destroying tube

PostPosted: Fri Mar 10, 2017 9:35 pm
by Iommic Pope
It'll be a bias resistor, but id take it in for a service in case it took anything else out.
Usually when this happens the tube cops most of the fault and as a result, eats shit and dies.
Happened in my pro tube when i first got it. Was like a fucking electrical storm in the power tubes. Ended up destroying the nice NOS mullards that were in there.
So pissed.
So you'll need new tubes and I'd get it looked over, just in case theres dry joins or some other shit arcing.

Re: piece of shit amp keeps destroying tube

PostPosted: Fri Mar 10, 2017 11:52 pm
by crochambeau
Is it the same socket? Could also be a failed screen resistor, I recall those Peavey amps run their B+ at something like maximum ratings for most tubes.

Co-sign the competent tech recommendation, though if you want to learn the trade you've got to start somewhere...

Re: piece of shit amp keeps destroying tube

PostPosted: Sat Mar 11, 2017 3:32 am
by Iommic Pope
Listen to this guy^.

Re: piece of shit amp keeps destroying tube

PostPosted: Mon Mar 13, 2017 9:58 pm
by Dr Satan
Classic 30s are notorious for shitty tube sockets and bad solder joints. Relatively easy fix for a competent tech though.

Re: piece of shit amp keeps destroying tube

PostPosted: Wed May 03, 2017 9:38 pm
by Boxbie
you got a guy? You in Syd?

Re: piece of shit amp keeps destroying tube

PostPosted: Tue Jul 04, 2017 9:58 pm
by controlFreak
Those amps are kind of a nightmare to work on.

I had a delta blues which is essentially the same amp but with a different cab and 15" speaker.

So many under rated components. The plate resistors are 1/4 watt throughout in those things for christ sake. Good Luck!